Java Problems Installing Sametime Community Server

Recently I was asked to install Sametime Community server in a new site.  I’ll be honest, I haven’t done a greenfield site install of Sametime in nearly a year, my work has primarily been upgrading (adding new elements) and maintenance.

As you probably know you can’t just install the Community Server onto Domino,  much of the admin and management features are now controlled solely inside the Sametime System Console running on WebSphere.  When installing WebSphere I installed version 8.5.5 as a base then applied the latest fixpack 12. (now version 13).  The Sametime elements only work with Java SE6 which used to be fine, during the WebSphere install I’d explicitly override its wish to install Java SE8 with a radio button to choose Java SE6, however that option disappeared on fixpack 11 and as of April 2018 Java SE6 is no longer supported even though Sametime still requires it and will continue to do so I suspect well into next year since the next release of a Community server is scheduled for H1 2019 and other elements for H2 2019.

Everything installed fine but then the servers with the applications couldn’t be stopped properly.  I had to uninstall WebSphere and the SSC entirely, then install base 8.5.5 with fixpack 8 (which I had to hand although other early fixpacks may also have worked) that allowed me to choose Java SE6 then install the SSC.  Once it was installed and I tested starting and stopping server elements I went ahead and upgraded the fixpack to 12.  WebSphere will warn you but continue to honour the Java version you originally chose , in this case Java SE 6, and not force an upgrade.

So. Websphere 8.5.5 with FP8 , then FP11.. 12.. 13 whatever you want.  The system requirements still say these are all supported so the loss of the option to choose Java SE 6 during fixpack install is what we are trying to fix.

One thought on “Java Problems Installing Sametime Community Server

  1. Interesting, as FP8 isn’t even supported. The system requirements only “allow” FP11 and higher.

Leave your thoughts here..

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.